BxLUG groupe des utilisateurs de GNU/Linux de Bruxelles

Espace membres

Installing Blackdown's Java Runtime Environnement (JRE) on Debian

Introduction

Java is not free and its distribution restrictions are such that it is not even possible to have a package included into non-free of Debian.

Blackdown is a project that provides Sun's Java environment to several distributions.

A mirror is available and maintained by Easynet [1] and Belgacom

Installation for Woody

Add the following line in /etc/apt/sources.list:
deb ftp://ftp.easynet.be/blackdown/debian woody main non-free
Then, launch, as root [2]:
apt-get update
apt-get install j2re1.3

Installation for Sarge

Add the following line in /etc/apt/sources.list:

deb ftp://ftp.tux.org/java/debian/ sarge non-free

Then, launch, as root:

# apt-get update
# apt-get install j2re1.4

Installation for Sid

This procedure is identical to Sarge's one. Add the following line in /etc/apt/sources.list:

deb ftp://ftp.tux.org/java/debian/ sarge non-free

Then, launch, as root:

# apt-get update
# apt-get install j2re1.4

Browser support

It will install at the same time Java support for Mozilla and all navigators based on Gecko engine like Galeon, Firefox, Epiphany, …

For Konqueror [3], install also package konqueror-nsplugins.

If you did not use Debian packages, please read INSTALL-j2re to configure browsers.

[1] Attention, as of March 10th 2005, Easynet mirror was outdated !

[2] to install the JDK, just replace j2re1.3 with j2sdk1.3

[3] but just starting from KDE 3.x

Bienvenue dans le monde du libre